Forecast Templates

From Genesys Documentation
Jump to: navigation, search

Configure and manage forecast templates that you can use to create forecasts for sites or business units that have little or no historical data.

Related documentation:

Tip
Starting in this release, WFM has a new interface for the Forecast module. If you have landed on this page by accident and are using the new Supervisors interface, see the "Templates" page in the Workforce Management Supervisor Help, which describes the new Forecast module.

Forecast templates help you create forecasts for sites or business units that have little or no historical data, but there are other uses for templates.  For example, you can create templates for service objectives, such as Average Speed of Answer, and Service Level. using forecast templates to apply different values for different periods of the day, instead of using a single value for the whole day.

Use WFM Web's forecast templates features to:

You can copy and paste data between a grid and a spreadsheet. For example, you can copy and paste from a Scenario Volumes view or Scenario Staffing view.

Templates list

Use the Forecast Templates List view to create, edit, and delete forecast templates.

Displaying the view

  1. In the Modules tree, click Forecast > Templates to activate the Templates List View.
  2. In the Objects tree, select a business unit, site, or template. Business units and sites expand to display their templates.
    • If you selected a business unit or site, the table on the right-hand pane shows the templates that correspond to your selection.
    • If you selected a template, the template properties appear in the Data tab.
    For detailed information, see the Data tab, Activities tab, and Graph tab in the template properties.

Using the table

The Templates table shows each template's name, type, associated site, and date range.

To filter the table so that it shows more or fewer templates:

  • Select or clear check boxes in the Show Template Types pane at the top.

To select a template for editing or deletion:

  • Click the template's row in the table.

Managing templates

You can use the following buttons on the Actions toolbar (these commands also appear in the Actions menu):

New Opens the New Forecast Template dialog.
Edit Opens the Forecast Template Properties view for the selected template.
Delete Deletes the selected template after first displaying a dialog box asking you to confirm your choice.

Template properties

The three tabs in the Template Properties view are described in this topic. Use the settings in these tabs to edit forecast template values and activities in table and graph formats.

Data tab

Use the Data tab to edit a forecast template's values in a table format.

The boxes at the top of the tab contain the template's name, associated site, business unit, type, and total or average value. The table lists timesteps and corresponding values for the template's activities.

To edit values:

  1. Select the value in the right column and replace it with the value that you want.
  2. Repeat this for other timesteps that you want to change.
    You can use the vertical scroll bar on the right to display more timesteps.
  3. Click Save to save your changes to the template.

Graph tab

Use the Graph tab to view a forecast template's values in a graphical format.

To adjust the graph's displayed time interval, use the Display Date drop-down list.

  • If you select Whole Period, the graph's horizontal axis indicates:
    • Days of the week, for non-overlap templates.
    • All dates in the template, for overlap templates.
  • If you select an individual weekday (for non-overlap templates) or a specific date (for overlap templates), the horizontal axis indicates timesteps.

The graph's vertical axis identifies the values shown in the graph.

Activities tab

Use the Activities tab to modify the activities associated with a forecast template.

  1. Select the check boxes beside the activities that you want to associate with the template.
  2. Clear the check boxes beside the activities that you want to remove from the template.
    The check boxes show activities belonging to the business unit or site with which the template is associated.
  3. Use the vertical scroll bar on the right to display more activities.
  4. Click Save to save your changes to the template's activities.


Creating forecast templates

Use the New Forecast Template dialog box to create a new template, but first watch the video.

To create a template:

  1. Click New in the Forecast Templates List view toolbar
    The New Forecast Template dialog box opens.
  2. Enter a Name for the template.
  3. In the Associated drop-down list, select the site for which you are building this template.
  4. Click the Type drop-down list to select the template type.
    See a list of template types below.
  5. Select a template from the Based On drop-down list If you want to use settings from a previously configured template.

Procedure continued...

  1. Enter a number for the Initial Value.
  2. If you are creating an overlap template, enter the Start and End dates.
  3. Select the Activities that you want to be associated with this template.
    Selecting activities enables you to control which templates are used when forecasting for specific activities.
  4. Click OK.
    The forecast template is now available in the Forecast Templates List view.

What does the initial value represent?

The initial value you enter in in the procedure is a minimum value that applies to all timesteps. After you have created the template, edit it to adjust the precise values for each timestep. WFM Web interprets the initial value differently, depending on the type of template. For example, if you are creating an Interaction Volume template, the initial value might be 8 (calls per timestep). See Template properties: Data tab for details.

Forecast template types

  • Interaction Volume—Number of interactions per timestep. When you save historical IV or AHT for a multi-site activity as a template, only multi-site activity data are saved, never the sum of underlying activities.
  • Average Handle Time—In seconds. See note above.
  • Service Level Percentage—As a percentage. See the Tip below.
  • Overheads—As a percentage. See the Tip below.
  • Indirectly Occupied Time—As a percentage. See the Tip below.
  • Maximum Occupancy—As a percentage.
  • Interaction Volume Overlap—Number of interactions per timestep.
  • Average Handle Time Overlap—In seconds.
  • Staffing—Number of agents (full-time equivalents) to be scheduled for each timestep. This can be either calculated by WFM (Calculated Staffing) or set by the user (Required Staffing), or you can use both Calculated and Required values in a forecast. See the Tip below.
  • Average Speed of Answer—In seconds. See the Tip below.
Tip
You can create these templates at the business unit level and apply them when building a multi-site activity staffing forecast.

Save as Template

Use the Save As Template dialog box to create a new forecast template from existing data. You can open this dialog box from the following views:

To complete the dialog box:

  1. Enter a name for the new template into the Name field.
  2. Select the site to which you want this template associated from the Associated drop-down list.
  3. Select the template type from the Type drop-down list.
    The Based on drop-down list and the Initial Value text box are disabled. You cannot alter their default entries.
  4. Select or enter the Start date and End date into the corresponding fields in the Source Dates area.
    The date range for regular, non-overlap templates must be one week. If you enter a different date range for a regular template, WFM Web automatically adjusts it to one week. For Overlap templates, which fill in gaps in historical data, you can specify start and end dates.
  5. Select or enter the Start date and End date into the corresponding fields in the Target Dates area.
    You can select Target Dates that are different from Source Dates for these template types
    IV Overlap, and AHT Overlap.
  6. Select the Activities that you want to be associated with this template.
  7. Click OK.
    The new forecast template now appears in the Forecast Templates List view.